summaryrefslogtreecommitdiff
path: root/hw/kdrive/smi/Makefile.am
diff options
context:
space:
mode:
authorMatthew Allum <mallum@openedhand.com>2006-08-29 22:07:15 +0100
committerMatthew Allum <mallum@openedhand.com>2006-08-29 22:07:15 +0100
commit5ddbf4bcd46fe0d3d682668c2748c712fea410ae (patch)
tree46eef47d19ec7ea82f7af69d4ebf81fad1d05fc3 /hw/kdrive/smi/Makefile.am
parent942b4369990a255257f66835caf8671432c405a3 (diff)
Re-add support for tslib (1.0 release) and Xcalibrate extension.
Diffstat (limited to 'hw/kdrive/smi/Makefile.am')
-rw-r--r--hw/kdrive/smi/Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/hw/kdrive/smi/Makefile.am b/hw/kdrive/smi/Makefile.am
index f7f0a6675..86a9ea947 100644
--- a/hw/kdrive/smi/Makefile.am
+++ b/hw/kdrive/smi/Makefile.am
@@ -6,10 +6,6 @@ INCLUDES = \
bin_PROGRAMS = Xsmi
-if TSLIB
-TSLIB_FLAG = -lts
-endif
-
noinst_LIBRARIES = libsmi.a
# smivideo.c # not ready yet
@@ -32,7 +28,10 @@ SMI_LIBS = \
Xsmi_LDADD = \
$(SMI_LIBS) \
@KDRIVE_LIBS@ \
- @XSERVER_LIBS@ \
- $(TSLIB_FLAG)
+ @XSERVER_LIBS@
+
-Xsmi_DEPENDENCIES = $(SMI_LIBS)
+Xsmi_DEPENDENCIES = \
+ libsmi.a \
+ $(top_builddir)/hw/kdrive/fbdev/libfbdev.a \
+ $(top_builddir)/hw/kdrive/vesa/libvesa.a